Help with hacking a phone/installing a custom rom

Nicholas Leippe nick at leippe.com
Tue Sep 20 13:42:28 MDT 2016


You don't need to root it to boot a custom rom--rooting only affects
user-land after you have booted.

What you need to do is unlock your bootloader.

> fastboot oem unlock
or
> fastboot flashing unlock

see:
http://www.howtogeek.com/239798/how-to-unlock-your-android-phones-bootloader-the-official-way/

Without that, you won't be able to boot a custom rom because the bootloader
doesn't see a system image that passes its tests.


On Tue, Sep 20, 2016 at 1:08 PM, Jeff <ml at mindstormdevelopment.com> wrote:

> Is there anyone on this list who happens to be good at installing custom
> Roms on an android phone? I have been trying and failing over and over.
>
>
> I'm on a Sprint Samsung Galaxy S3
>
>
> For each step of the process I've tried different things just in case the
> issue was somehow with one of them:
>
> 1) So for instance for the rooting step, I've used different rooting tools
> (and according to root checker apps, each one succeeds).
>
> 2) For installing a custom recovery, I've used both  and TWRP, and they
> both seemed to install well and be functional.
>
>
> 3) For the next step of installing a ROM, I've tried about 5 different
> custom Roms.
>
> I've followed lots of different tutorials -- but every single time after
> everything is all installed and the phone is doing it's final reboot to
> boot into the new OS it just hangs. If I then force a turn off (hold down
> power for a long time). It turns off and the promptly reboots - so I guess
> I've got both a "hanging boot" and a "boot loop" - so a "hanging boot loop"?
>
> Online tutorials say if you get here to install the factory default ROM,
> and so I do. Everything works perfectly in the default ROM. After getting
> it back to a good state and using it for a couple of days, I try my luck
> again and once again go through the rooting, recovery, custom ROM process
> where everything seems to go OK until the final reboot where it once again
> gets in a hanging boot loop.
>
>
> A few places I've read online talk about how if you get a hanging boot
> loop and try to do various data wipes from recovery and they don't work
> there might be something physically wrong with your phone - so I might
> wonder that except for the fact that each time I am able to reinstall the
> stock rom and it works just perfectly.
>
>
> Any ideas?  I've spent probably a good 40 hours on this over the last 5 -
> 6 weeks and am past the end of my rope.  Any tips would be so incredibly
> appreciated!
>
> Thanks,
>
>
> Jeff
>
>
> /*
> PLUG: http://plug.org, #utah on irc.freenode.net
> Unsubscribe: http://plug.org/mailman/options/plug
> Don't fear the penguin.
> */
>


More information about the PLUG mailing list