Bluetooth Headset and Lenovo T-61 on Debian 7.0

Levi Pearson levipearson at
Thu Sep 19 13:42:50 MDT 2013

On Thu, Sep 19, 2013 at 12:20 PM, Charles Curley
<charlescurley at> wrote:
> On Thu, 19 Sep 2013 10:24:43 -0600
> Charles Curley <charlescurley at> wrote:
>> Thanks. I'll try some things this morning, and maybe shift to
>> PulseAudio. If those two don't produce useful results, I may call on
>> you.
> Well, now! I tried a few more alsa tricks. No go. Fearing the worst, I
> then did some backups. I then installed PulseAudio following the
> apt-get command line in
> (after excising two package names that no longer exist). I then purged
> every package with "alsa" in the name.
> I fired up vlc, and it played a MP3 file for me immediately. Wow!
> I then fired up the PulseAudio volume control, and went to the
> Configuration tab.
> I then turned on the headset. It appeared almost immediately in the
> configuration tab. I set it to use A2DP instead of the telephony
> duplex. then to the Playback tab on the PulseAudio volume control,
> where I selected the headset as the output device. Then I did the same
> with a Flash video from youtube.
> That was it!
> No configuration hassle! No broken packages (except as noted)! Are you
> sure this is a Linux package? :-)
> Thanks for the help.

The PulseAudio guys, and Pottering in particular, got a lot of flak
over PulseAudio when it was first introduced into distros. The Linux
audio situation has been problematic forever, and introducing a new
piece in a very fragile ecosystem always breaks things. They've worked
very hard to fix the issues, though, and I think PulseAudio generally
does an excellent job at making audio just work like you'd hope it
would, and it even does a relatively good job at keeping the latency
overhead that a multiplexer necessarily introduces to a minimum. I
think people who avoided it previously due to hearing bad things about
it would generally be pleasantly surprised by it if they gave it a

There are a couple of scenarios where it is rather opinionated about
how it should be run.  It really wants to run one session per
logged-in console user, which is normally what you want, but when you
use it on a server or embedded gadget it is a bit awkward because no
one is logged in to a console at all.  It does allow you to run in
'system' mode but it has some strange restrictions on how it works
that way.

If you are doing networked audio, it has a built-in RTP-based audio
streaming plugin that will allow you to get roughly-synchronized audio
throughout your network.  That mode only supports multicast
distribution at the moment, though, which generally interacts poorly
with WiFi.  If you have a wired network, however, it can be pretty

Anyway, I'm glad you got your headset problem resolved!  Happy listening. :)


More information about the PLUG mailing list