Hosed yum on Fedora 18 x86_64

Barry Roberts blr at robertsr.us
Mon Aug 12 08:51:24 MDT 2013

A few weeks ago we had a brief power outage here in Orem, and the one
computer in my house that's not on a UPS was in the middle of a big
'yum upgrade'  Now lots of things are broken, and I can't get it
fixed, and I don't really want to re-format and re-install (so
Windowsy, ew), but that's about what I'm down to.

'yum-complete-transaction' would just hang and not do anything for
hours, so I finally ran it with '--cleanup-only'

No Qt programs work because of incompatible library issues, but the
real problem is yum won't do anything because there are tons of
duplicates, or so it thinks.  If I try to 'package-cleanup
--clean-dupes'  it fails because it thinks it needs to remove systemd,
yum, and the kernel.  I've also done 'yum clean all' and tried to 'yum
history rollback' the botched transaction, but that fails also. I
don't remember the exact error.

I tried to get yumdownloader to just download the latest rpms so I
could install them with 'rpm -Uvh --force', but yumdownloader fails
because of all the duplicates.

I've exhausted my knowledge of yum/rpm and google.  Anybody got any
suggestions before backup, format, and re-install?


More information about the PLUG mailing list