Speaking of insufficient skill

S. Dale Morrey sdalemorrey at gmail.com
Tue Jun 7 02:39:59 MDT 2011

Ok I hate to admit this but about 4 years ago in a fit of something or
other I decided to try a friend of a friend out on gOS (a super easy
to use ubuntu variant).  This machine was a refurbed hand me down and
designed for Windows XP, with a P4 processor, 512MB of RAM and an 80
It worked great until about 3 months ago when suddenly things like
flash (adobe) started to "fail".
This friend of a friend contacted our mutual friend, who then
contacted me and asked me to come look at it.

Long story short I found out that her gOS repositories were no longer
responsive, which of course means her software was simply aging out.
The flash failing thing was really just a warning to upgrade her flash
to version 10.
After a little more research I found out that gOS hasn't been updated
in a very long time and appears to be abandoned.

I tried to perform a back up of her data and found that the DVD burner
had failed completely.
Thumb drives would plug in and be recognized, but fail to mount, even
when mounted explicitly.

Mistakenly trusting my instincts I changed her apt-sources to Natty
and performed an "apt-get dist-upgrade".

This upgraded everything, it took a few hours but was completely
successful with no errors.
When the upgrade completed and I performed a reboot,  X would no
longer load properly.
It would go to a configuration screen at 800x600 but then would go no
further causing a hard freeze that required power cycling to clear.

gOS is based on Hardy and I took it all the way to Natty with a
dist-upgrade, so I get that some things were bound to break, but X no
longer loading is something I wasn't really considering as a
possibility.  Thinking more on the subject I guess I should have
remembered that the XFree86 to Xorg transition did happen during this
time IIRC.

To make matters worse, this machine has an intel chipset and I'm
actually starting to get a bit suspicious that the chipset itself is
failing as evidenced by a failure to load drivers and recognize
plugged in peripherals.

My next step is to try a clean install of Natty, but she is elderly
has had this computer since 2008 and by sheer force of luck has never
had cause to back a single thing up.  All of her pictures, taxes etc
are on the hard-drive.  For the record it is my understanding that
during this time she only ever powered the machine off twice and one
of those was a power outage.

Regardless of whatever else may be wrong with this machine a backup at
this stage is imperative.
I would like to figure out a way to perform a backup in-situ without
removing the hard-drive since I no longer own, or even have access to
a machine with a PATA IDE connector and the cost of dock would exceed
the cost of a new machine.

When I plug a USB thumbdrive into any of the USB ports, according to
dmesg about half fail to recognize anything connected, and the ones
that do freak out with an "unknown USB block device connected"
message.  Regardless of where I plug the darn thing in, I see nothing
in /dev/sd* except for /dev/sda which is the current HD.  I have tried
this with multiple good thumb-drives and somehow 2 managed to hard
fail and become completely unusable in other machines when plugged in,
although it those two were both plugged into the same port, so yeah
I'm not trying that port again, but there are 8 ports on this machine,
4 up front and 4 in back.  The USB port blowing things out smells very
much like a power supply issue, but before I troubleshoot further I'm
determined to get a backup of her data for her.

Any ideas on how to proceed in this situation?

More information about the PLUG mailing list