echo -e '\a' fails on Ubuntu 10.10

Charles Curley charlescurley at
Sat Dec 4 22:08:22 MST 2010

On Sat, 4 Dec 2010 21:22:52 -0700
Andrew McNabb <amcnabb at> wrote:

> On Sat, Dec 04, 2010 at 07:15:39PM -0700, Charles Curley wrote:
> > 
> > It is checked and that is not helping. Thanks
> I just tried playing with this on my machine.  To get a terminal
> bell, I had to check "Terminal bell" in the profile (as you have
> already done), and then fixed the settings in Sound Preferences.
> Specifically, under the Sound Effects tab, I raised the Alert Volume
> and changed the Sound Theme from "No sounds" to "Default".  I now get
> a old-school Mac-style alert sound when I run "echo -e '\a'".
> Does it help to double-check your Sound Effects settings (Alert Volume
> and Sound Theme)?

Thanks. I tried that, and all the other custom sounds. I can hear the
sounds when I click on them to select them, but not when I run the echo

I have one of the sounds, the "sonar", set up as a new mail alert. It
works. The command is:

/usr/bin/ogg123 -q $fileToPlay



That works just fine.

I should also mention that these sounds have worked in the past, that
this is a recent fresh installation of 10.10 (replacement hard drive),
and the computer is a Lenovo R51,



Charles Curley                  /"\    ASCII Ribbon Campaign
Looking for fine software       \ /    Respect for open standards
and/or writing?                  X     No HTML/RTF in email    / \    No M$ Word docs in email

Key fingerprint = CE5C 6645 A45A 64E4 94C0  809C FFF6 4C48 4ECD DFDB

More information about the PLUG mailing list