Apache/mod_ssl crashing on startup [SOLVED]

Barry Roberts blr at robertsr.us
Wed Mar 18 15:45:33 MDT 2009

On 03/18/2009 03:11 PM, Chris wrote:
> On Wed, Mar 18, 2009 at 1:29 PM, Barry Roberts<blr at robertsr.us>  wrote:
>> strace httpd -k start shows the last system calls (I can send the full
>> output) as either a whole bunch of:
>> time(NULL)                              = 1237404201
> Did you run httpd inside gdb and examine the stack backtrace,
> registers, and local variables once the SEGV fired?
I had composed long and mostly useless replies to Mr. McNabb's and Mr. 
Jansen's helpful responses when I tried this.  Turns out the latest 
Legato Networker client (which I had just installed a couple of months 
ago) added /opt/lgtonmc/bin/ to /etc/ld.so.conf.

So gdb showed me this:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208408304 (LWP 26795)]
0x001c08d9 in CRYPTO_new_ex_data () from /opt/lgtonmc/bin/libldap-2.3.so.0

And I (almost) immediately realized that httpd shouldn't be using any 
libraries in /opt/lgtonmc/bin.

After I removed that line from ld.so.conf and ran ldconfig everything is 
feeling MUCH better now.  So thanks to all for the help.

PLUG Rocks.


More information about the PLUG mailing list