anyone familiar w/sun hardware, and sun OpenBoot?

Nicholas Leippe nick at
Fri Jan 16 15:54:32 MST 2009

On Fri Jan 16 2009 15:05:39 MT Morales wrote:
> On some Sun systems you could get locked out of console if the RSC is
> already the default serial (or IP based) console, and if the RSC admin
> account is unknown, you may even have to reset the RSC using the switches
> on the card itself.  If it's not too much of a hazzle, I'd put the card
> back in and verify the RSC settings from the OS (assuming you have access
> to it when you boot it up all the way).

There is no OS. There are no drives.
I'm attempting to boot to cdrom. As of now, I cannot manage to get a working 
kernel. Every version and configuration I've tried from 2.6.25 through 
yesterday's sparc-linux git repo hangs at some point in the kernel 

> If IP (static or dhcp) is not set on the RSC, then you should try setting
> your serial session through the RSC port. Obviously if the right speed or
> control bits are not used, you may be unable to get any output at all. I'd
> check the specific serial settings for that v880 model standard serial
> port, and RSC.

I have never tried to use the RSC card. I have successfully used the ttya 
port, and printenv shows sane settings for both current and default serial 
Maybe there's some obp var that I'm missing, I went through the entire manual 
and looked at each one that seemed like it might be relevant.
Is there a way to change the "default" value of obp vars? Or are they really 
I have yet to successfully boot outside of diagnostic mode.
I can power-on to diagnostic mode, (wait for the tests to finish), then:

ok: boot cdrom

at which point it reboots, skips the tests, then boots the cd.

But, if I power up in normal mode, it gets to the ok: but does not accept any 
input at that point--I presume the console has been redirected to never-never 
land. Why would it redirect the console at that point--right after it prints 
the prompt? Makes no sense to me.

More information about the PLUG mailing list