system not able to send mail to external address

Wade Preston Shearer wadeshearer.lists at
Sat Feb 7 09:24:34 MST 2009

Within /etc/aliases on my server, I have "root" pointing at an outside  
address (such as "user at"). This means that any  
mail sent to root (such as my daily LogWatch emails) are forwarded to  
this external address. This has worked for several years. A month or  
two ago, I changed the address to a different address. Since then, I  
have had significant problems. I get returned mail emails from the  
Mail Delivery Subsystem (mailer daemon) stating that "the address had  
permament fatal errors) and that after trying for five days, the  
message will be deleted from queue. My first thought was that my  
server could not communicate with my new email providers so I ran a  
few tests. Using the command line mail client, I sent test messages  
from a non-root user's account to both this new address and to "root."  
Both were delivered successfully.

Does anyone have any idea why mail sent to root from the command line  
mail client would be forwarded ("expanded") to the alias email address  
and delivered successfully while email messages generated by scripts  
(such as LogWatch and Mailman) are not forwarded ("expanded")? Also,  
here's the other thing that is boggling my mind: why do I get the  
failure email but not the original email?

Here is an example of the returned emails:


The original message was received at Mon, 2 Feb 2009 04:03:12 -0700
from localhost.localdomain []

   ----- The following addresses had permanent fatal errors -----
user at
    (expanded from: <root at>)

   ----- Transcript of session follows -----
user at Deferred
Message could not be delivered for 5 days
Message will be deleted from queue
Reporting-MTA: dns;
Arrival-Date: Mon, 2 Feb 2009 04:03:12 -0700

Final-Recipient: RFC822; root at
X-Actual-Recipient: RFC822; user at
Action: failed
Status: 4.4.7
Last-Attempt-Date: Sat, 7 Feb 2009 04:39:42 -0700
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 2431 bytes
Desc: not available
Url : 

More information about the PLUG mailing list