Lost Java

Scott Jones sanchiro at gmail.com
Thu Dec 17 11:53:24 MST 2009

I recently encountered trouble with Java, i.e., Java stopped working
on my ubuntu 9.10 box, running on amd64. It's worked fine in the past,
and I can't nail down what changed on my system. I just know that now
I can't get Java working; it won't load things like Shawn Powers' tech
tips on linuxjournal.com or any other java content.

Here's what I have tried. I believe the problem may have started when
I downloaded something from Adobe. In any event, now it is broken.

I had some help yesterday cleaning up a broken package, which happened
to be the adobe flash plugin. After running a few apt-get commands I
have that all cleaned up now, and was able to reload with 'apt-get
install flashplugin-nonfree' without any errors. The problem though is
Firefox 3.5.5, as well as 3.5.6 will still not play any java content.
The upgrade to the 3.5.6 firefox version had no appreciable effect on
this issue.

Suggestions? I have wanted an excuse to take my system down after a
thorough backup and rebuild to ext4 but I'd like to think I can figure
out why it's failing without having to resort to a reformat and


More information about the PLUG mailing list