Fedora Ethernet bridge

Nat Brown natjbrown at gmail.com
Fri May 16 15:43:49 MDT 2008

I installed Fedora 8 from the Live CD image on an HP DL320 server and
set it up in a data center to do mail relay.  Now I need to bridge the
two network cards in the server to act as a switch, while still having
it act in the mail relay role.  For some reason, I can't get this to
work properly.

/etc/sysconfig/network-scripts/ifcfg-eth0 has:

/etc/sysconfig/network-scripts/ifcfg-eth1 has:

I ran:
yum -install bridge* -y
to install the bridge utilities, then I ran:
brctl addbr br0
brctl addif br0 eth0
brctl addif br0 eth1
ip link set br0 up
ip addr add brd + dev br0
route add default gw dev br0

Now I when I check ifconfig, it shows that eth0 has gotten an IP
address in our DHCP range, as well as br0 having the ip address  Also, the computer connected to eth1 cannot ping the
router on eth0.  It gets a message from that the destination
is unreachable.

Any ideas?  Should I be going about this a different way?  Let me know
if I need to post additional information.  I'm still fairly new to
Linux, so you may also need to tell me where to look to find said

Nat Brown
natjbrown at gmail.com

More information about the PLUG mailing list