kernel BUG

Nicholas Leippe nick at
Fri Oct 26 16:03:00 MDT 2007

On Friday 26 October 2007, Andres Gonzalez wrote:
> Hi,
> When I run dmesg on my Fedora Core 7 box it has several entries like
> this:
>  =======================
> BUG: at kernel/irq/manage.c:33 synchronize_irq()
>  [<c1005e65>] show_trace_log_lvl+0x1a/0x2f
>  [<c1006417>] show_trace+0x12/0x14
>  [<c100649b>] dump_stack+0x16/0x18
>  [<c104927e>] synchronize_irq+0x4c/0x65
>  [<c10493cf>] disable_irq+0x27/0x2a
>  [<de1b05ab>] vortex_timer+0x65/0x39d [3c59x]
>  [<c1027698>] run_timer_softirq+0x104/0x168
>  [<c10247e8>] __do_softirq+0x80/0xf9
>  [<c100707d>] do_softirq+0x77/0x103

Dunno if this is relevant, but...changing my network card from my 
tried-and-true netgear 10/100 w/tulip chipset to a new-fangled netgear GigE 
w/rtl8169 chipset started causing kernel errors, and it would shut down the 
irq handler (preventing any network access).

Turns out the driver doesn't properly work with acpi. Specifying the 'irqpoll' 
kernel option, while not really cool IMO, seems to have resolved it for me.

ACPI apparently still has issues.

More information about the PLUG mailing list