CUPS won't work, nor other printing to xp shared printer

Dr. Scott S. Jones scott at
Thu Feb 1 09:39:18 MST 2007

CUPS won't work, and yet it does at home with similar setup. 

There's my dilemma. I run Debian 2.6.8 at my office. I frequently run
apt-get upgrade to assure I have the most up to date system, but I fear
running apt-get may have crippled CUPS. 

About 3 weeks ago, after the update / upgrade routine, CUPS stopped working.
It took with it the installed default printer to my linux box, which is a
network shared laser jet attached to a windows xp box on my LAN. 

The printer works fine from xp, as well, it prints JUST FINE, from win 98se
which runs under Win4Lin on my linux box. I just can't print from xpdf, or
using enscript or in mutt by issuing a print with 'p' command when reading
an item I want printed out. 

smbclient -L seth (name of the xp machine) works fine and shows the shared

I mentioned a home system similar to my work linux box. At home I run 2.6.7
Debian..and it prints just fine in character mode apps as well from firefox
or any other application. 

I can't help but think that some item which apt-get upgraded has crippled my
work machine. I open firefox and run 'localhost:631/' and it opens the main
screen but refuses to add a new printer, or to show jobs. It just grinds
apache 2 to a halt. I have not done anything with apache, but firefox seems
to be getting progressively slower on this machine. 


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : 

More information about the PLUG mailing list