Laptop suspend works?

Steve smorrey at
Mon Dec 3 00:43:31 MST 2007

Hi everyone,

Recently I decided it was time to get a new laptop so I purchased a
Compaq F712NR from Best Buy.
My reasons for purchasing this particular model are pretty simple.  It
had decent specs
Dual Core AMD Athlon X2 64bit (TK-53)  with 1 GB of RAM an 80 GB HD,
nVidia MCP Chipset, nVidia 6100 Graphics
Additionally it was dirt cheap at only $399 out the door!

Immediately upon purchasing the laptop I decided to blow away the
installed Vista Home Premium OS which was slow and buggy, and went
about installing Ubuntu.
Little did I know the ordeal I was about to embark upon.

First problem with the machine was that the Ubuntu LiveCD would appear
to boot and then freeze solid with alternating white and black lines,
this would cause the fan to spin up to somewhere near the speed of
light, and the only thing to fix it was to remove the power AND the
battery (pressing and holding the power button did nothing).

My next try was to use the alternate install CD for AMD64 and perform
a text mode install.
The install went off without a hitch other than the fact that it could
not get my wifi up even though it could see the card just fine.

Once the OS was installed, the system failed yet again to start in yet
again the same fashion requiring me to again pull the battery to get
it to power down.
At this point I went in to grub, and edited the boot lines to remove
the quiet and splash options.

This time instead of freezing with white and black stripes, it
actually showed me where the problem was.
The message was something like "Detected 300 usec TSC ClockSkew on
processor 2 fixing it up!" after which it would freeze.

Remembering my Dell Laptop had a similar issue (it would freeze during
boot with the new kernels) I again edited grub and this time added
"noacpi" to the kernel options.

Woohoo!  This time it booted!
But the Broadcom wifi card still could not be utilized, after
following along with about 20 guides on the subject I eventually added
ndiswrapper (restricted drivers for this card "Broadcom 4311 (rev 2)"
do nothing).  Ndiswrapper got the wifi to light up on reboot (computer
has a lighted switch that is red or blue depending on if Wifi is
functional).  With the wifi light blue I managed to see all the nearby
wifi points including my own but was sad to see that I could not
connect to any of them no matter how hard I tried.

Eventually I found similar problems with unrelated hardware and
tracked the problem down to an IRQ conflict.  So I added the following
lines to grub, "noapic irqpoll" .

Poof everything worked spectacularly well, except of course suspend,
resume and etc which were obviously disabled.

Fast forward about a month.

My boss tells me, he needs me to start testing some software under
Vista (I work from home right now).
The only "Vista" capable machine I own has had it's Vista partition
blown away including the mfrs restore partition.
The computer did not ship with media, and Compaq wants my first born
in exchange for said media.

I figure if I'm going to HAVE to run Vista I may as well go out and
purchase a copy and bill it as a business expense.
I go all the way and get Vista Ultimate.

Much to my dismay, Vista blew my Linux partition away during install :(
So after Vista is finally installed (6 hours of install and almost 5
more hours of updates), I go grab my beloved Ubuntu disk.

Being wiser I just used the AMD64 Alternate install disk rather than
even trying to get the liveCD going.
About 2 hours later I had a computer running Ubuntu and suffering from
the same freeze/crash problems as before.

But I remembered my lesson from last time, and added the "noapic
irqpoll" options to grub.
And no thats not a typo although it was originally.

Imagine my surprise when lo and behold my mistyped option "noapic"
instead of "noacpi" appeared to allow the system to boot up normally.
Imagine my further surprise when installing NDiswrapper and the driver
for the Broadcom 4311 (rev 2), went off with out a hitch and my
wireless worked!

Now imagine my surprise today when I let my wife use the laptop, as
she was walking away she put it into suspend (I've never had suspend
work on a laptop so I didn't ever bother to try) and when I came back
to it, it came right back to life!

My suspend and resume on this thing take about 1/3 (I've clocked it),
of the time as suspend and resume under Vista Ultimate.

Anyways just wanted to drop a line and let everyone know, in case you
had considered getting one of these Compaq F700 series, that yes Linux
can in fact work on them.  Just add the following lines to the kernel
options in the boot loader "noapic irqpoll".

I hope this was enlightening!


More information about the PLUG mailing list