Crashed pvmove

Clint Savage herlo1 at
Mon Apr 23 18:50:26 MDT 2007

On 4/23/07, Jordan Curzon <curzonj at> wrote:
> I am using LVM on a software raid 1 disk and tried to use pvmove. It
> got an IO error and crashed at 62%. When I rebooted the box and tried
> to restart pvmove it said that the number of segments doesn't match
> the metadata. Now the logical volumes report an IO error when I try to
> mount any of them. The logical volumes have XFS file systems on them
> and the data we are trying to recover are the innodb files from mysql
> This has really important data that we failed to backup. Does anyone
> have any ideas about how to fix pvmove or find the innodb files on the
> raw disk?
> -Jordan Curzon
> /*
> PLUG:, #utah on
> Unsubscribe:
> Don't fear the penguin.
> */


There is a backup of your lvm in /etc/lvm/backup (hopefully).  It should
help you identify what problems might exist.  Also, I found a very helpful
tutorial over at Linux Journal a while back when I destroyed my LVM.  My
recovery was fairly successful, I hope yours will be too.

Here's the links: - My
crashed LVM story - A very useful LJ article.



More information about the PLUG mailing list