Need Partition Table GURU

Dr. Scott S. Jones scott at
Fri Oct 6 05:51:29 MDT 2006


> Dr. Scott S. Jones wrote:
> > root at 2[knoppix]# fdisk -l /dev/sda
> > 
> > Disk /dev/sda: 80.0 GB, 80026361856 bytes
> > 255 heads, 63 sectors/track, 9729 cylinders
> > Units = cylinders of 16065 * 512 = 8225280 bytes
> > 
> >    Device Boot      Start         End      Blocks   Id  System
> >    /dev/sda1   *           1          34      273073   83  Linux
> >    Partition 1 does not end on cylinder boundary.
> According to this thread [1], this happens when you tell fdisk to
> partition a disk using "megabytes" instead of "cylinders".  Sometimes
> the number of megabytes does not equal an integral number of cylinders.
> This in itself is supposedly not a problem, as long as the partition
> starts cleanly on a "cylinder".  Ending on a "cylinders" is not.
> When you boot up, what is the exact error message the system is giving you?

I ran gpart and then testdisk and both of those helped clean up the
partition table. The REASON though, I found that it was not booting up,
after running those tools on this drive, came down to the SATA controller. 

I thought the controller was the trouble, so I bought another and it
happened to be made by the same people at Silicon Image. Anyway, it would
hang right at the same spot. I thought, change the controller back to the
original, which had worked over a year...and it booted right up. 

Since then I have had to run fsck.ext3 on various partitions to clean them
up, but it appears it is working well now. I still have to contact Silicon
Image and find out why their newer card would disallow this drive from

Thanks for your help,


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : 

More information about the PLUG mailing list