Troubles getting a software RAID 5 to work correctly

Kenneth Burgener kenneth at
Sat Nov 25 12:36:33 MST 2006

Kenneth Burgener wrote:
> The array was created using the following:
> root at fileserver ~]# mdadm --create /dev/md3 --verbose --level=raid5
> --raid-devices=3 /dev/hd[ceg]1
> I did notice that when I create the array I get a few weird indications,
> such as:
> root at fileserver ~]# cat /proc/mdstat
> Personalities : [raid6] [raid5] [raid4]
> md3 : active raid5 hdg1[3] hde1[1] hdc1[0]
>       240974720 blocks level 5, 64k chunk, algorithm 2 [3/2] [UU_]
> The "UU_" would seem to me to indicate that one device is in failure
> mode?  When I check the details of the array, there is no indication
> that there is a failed device:

It turns out, for what ever reason, the 3rd device (in what ever
configuration I used) was not being processed.  I tried using raid6, and
the disks were processed correctly.  I tried raid1, and the mirror was
processed correctly.  Raid5 was the only one that would not processes
correctly.  I reinstalled the OS using Fedora Core 5 64bit, and upon
creating the raid5 array the disks were processed correctly.  This leads
me to believe there may have been a problem with the raid5 module or the

Thanks for all of your help,

More information about the PLUG mailing list