iptables Firewall

Tyler Strickland tyler at tylers.org
Sat Jan 14 11:20:18 MST 2006

On 01/14/2006 10:50 AM, Robert Lawrence wrote:
> I've been having some problems with a firewall script that I've written.
> I'm running debian if I run the script at bootup the script doesnt work.  If
> i disable the script at bootup and then run it from the command line
> everything works as it should but if I run it at bootup I can't connect in
> or out until I either flush and rerun the script or simply rerun the
> script.  I've added loggin to the input chain and nothing is logged until I
> rerun the script.  It's as if the script when run upon bootup locks down
> every port but doesnt open the ports I've specified further on in the script
> even though I see all of the echoed messages that are placed throughout the
> script.
> I was wondering if anybody has had a problem similar to this in the past and
> has any ideas.  I attached the script as well as the flush script I'm
> using.  Any help would be appreciated.

At what runlevel does the script run?  It may be profitable to look in 
the startup directory for the runlevel and see at what point in the 
bootup sequence it runs.  It may be that some other script that runs 
after it modifies your settings.


More information about the PLUG mailing list