Treo 650 experience?

Barry Roberts blr at
Thu Oct 13 22:13:22 MDT 2005

On Thu, Oct 13, 2005 at 09:38:11PM -0600, Doran Barton wrote:
> As for Linux interoperability- It worked fine with FC3 and didn't work at 
> all with FC4. It would help if you told us what distro and kernel version 
> you're using.

Just thought I would see if anybody else was using one before I went
into too much detail.

I quickly found enough info on FC4 udev/hotplug problems with USB
palms, that I gave up on it pretty quick.  I've tried my FrankenDebian
(I think it's a mixture of testing and unstable, but I set it up over
a year ago and have just been apt-get dist-upgrade'ing periodically
since), and openSUSE 10.0.  Exact versions of kernels, pilot-link,
etc. are at work.
> I've managed to get USB syncing working with FC4 by using latest kernels 
> and some development packages of pilot-link.

I got USB sync to work once on my debian laptop.  Now I think I'm
running into the timing issues
(  Gonna
try some of those suggestions tomorrow.

> I was able to get DUN over bluetooth working by following Dax Kelson's 
> excellent tutorial 
> <> 
> on the subject. But now, it doesn't work at all. I suspect there is 
> yet-another product defect in my Treo related to bluetooth.

Tried that.  Verizon has DUN disabled, but AFAICT, you need ppp to
sync over bluetooth because pilot-link doesn't support direct sync
over /dev/rfcomm0 (yet).

Here's what I can't get to work with bluetooth on fc4 and debian, and
openSUSE.  I'm supposed to create a "Connection" in the preferences
(to a Computer, over bluetooth), and it's supposed to find my
computer.  It never does.  It's not a hardware issue (I don't think)
because if I go to add my computer as a trusted device or a hotsync
device, it finds it.  Just not when I'm adding a Connection.  And
'hcitool scan' does see the treo.

I can get a /dev/rfcomm0, and if I open it, the treo pops up a box
(something like "connection started", or something).  So I thought I
would go ahead and try ppp, but chat and minicom never get a response
from AT commands.  Dunno if that's the same problem, different
problem, or if it just doesn't work without the connection created on
the treo side.

> All that said, I love the device. I love being able to SSH in to a box from 
> almost anywhere. I love the keyboard and the text-messaging apps. I love 
> the hi-res color screen. Now if it was just solid and reliable!

I love the fact that even though the only sync I've gotten to work so
far was a fluke, I've still got pssh, plucker, iSilo, an rpn
calculator, and a bunch of e-books installed because I just plopped
them into the palm/Launcher directory of the mmc card in my openSUSE
box at home with a usb card reader.  And running mutt and centericq
over ssh on it just makes me grin uncontrollably.

But, yeah, so far, my sentiments exactly on the connectivity part.
Mine hasn't re-booted yet, so I'm still willing to blame my problems
on FC4 bugs, immature support for the 650, and MAYBE even luser error.


More information about the PLUG mailing list