Problems mounting vfat partitions

Matthew Ross Walker matt at
Tue Nov 22 11:30:00 MST 2005

In the last week, my linux system has decided that it doesn't like vfat
partitions. I don't particularly blame it, but it's annoying, since I
use a lot of devices with vfat filesystems on them.

I've got an external USB harddrive that has worked for months. The other
day, I had to reboot, and the drive just stopped working. I plugged it
into my windows machine, and it mounted right up. I ran every disk check
I can get my hands on, and they all come up clean.

The hardware is still being detected properly on Linux. But it refuses
to mount.

mwalker ~ # mount /mnt/usb1
mount: wrong fs type, bad option, bad superblock on /dev/lacie_drive,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

mwalker ~ # cat /etc/fstab
# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/hda1               /boot           ext2            noauto,noatime
        1 1
/dev/hda3               /               reiserfs        defaults
        0 0
/dev/hda2               none            swap            sw
        0 0
/dev/lacie_drive        /mnt/usb1       vfat
auto,users,uid=1000,gid=100,dmask=007,fmask=117 0 0

# NOTE: The next line is critical for boot!
none                    /proc           proc            defaults
        0 0
none                    /dev/shm        tmpfs           defaults
        0 0

/dev/hdc                /media/cdrom            auto
user,exec,noauto,managed 0 0
/dev/sda1               /media/usbdisk          vfat
user,exec,noauto,utf8,managed 0 0

mwalker ~ # ls -la /dev/lacie_drive
brw-rw----  1 root disk 8, 0 Nov 22 10:59 /dev/lacie_drive

mwalker ~ # ls -la /dev/sda1
lrwxrwxrwx  1 root root 11 Nov 22 10:59 /dev/sda1 -> lacie_drive

mwalker ~ # dmesg | tail
 sda: sda1
Attached scsi disk sda at scsi1, channel 0, id 0, lun 0
Attached scsi generic sg0 at scsi1, channel 0, id 0, lun 0,  type 0
usb-storage: device scan complete
FAT: bogus number of FAT structure
VFS: Can't find a valid FAT filesystem on dev sda.
FAT: bogus number of FAT structure
VFS: Can't find a valid FAT filesystem on dev sda.
FAT: bogus number of FAT structure
VFS: Can't find a valid FAT filesystem on dev sda.

mwalker ~ # fsck.vfat -a /dev/sda1
dosfsck 2.11, 12 Mar 2005, FAT32, LFN
Currently, only 1 or 2 FATs are supported, not 0.

mwalker ~ # uname -a
Linux mwalker 2.6.14-gentoo-r2 #1 PREEMPT Tue Nov 22 10:32:18 MST 2005
i686 Intel(R) Pentium(R) 4 CPU 2.80GHz GenuineIntel GNU/Linux

mwalker ~ # lsmod
Module                  Size  Used by
nvidia               3707912  8
smbfs                  63480  2
snd_pcm_oss            48544  0
snd_mixer_oss          17280  1 snd_pcm_oss
snd_seq_oss            32640  0
snd_seq_midi_event      6016  1 snd_seq_oss
snd_seq                49936  4 snd_seq_oss,snd_seq_midi_event
snd_seq_device          7052  2 snd_seq_oss,snd_seq
snd_intel8x0           30304  2
snd_ac97_codec         93820  1 snd_intel8x0
snd_ac97_bus            2048  1 snd_ac97_codec
snd_pcm                82696  3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
snd_timer              21636  2 snd_seq,snd_pcm
snd                    46308  13
snd_page_alloc          8712  2 snd_intel8x0,snd_pcm
dm_mod                 52796  0
usb_storage            31364  0

I was running 2.6.12-gentoo-r9 previously, but upgraded today, in the
hopes that it would fix the problem.

The above drive is an actual external harddrive, but the same thing is
now also happening to USB flash drive that I use. It also mounts
properly in windows. I tried copying everything off the flash drive, and
reformatting it, (full, not quick) but it didn't make any difference. I
don't have a handy system with enough disk space to do the same thing
for the USB harddrive, but I doubt it would work anyway.

Any tips? Any other information needed?
Matthew Walker
The Brain Garden, Inc
matt at
Work: (801) 655-1075
Home: (801) 491-2079
Page: (801) 283-9887 (Emergencies Only)

Random Quote:
BOFH Excuse #265:

The mouse escaped.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: OpenPGP digital signature
Url : 

More information about the PLUG mailing list