subversion woes!

tuxgirl at tuxgirl at
Thu Mar 3 22:43:57 MST 2005

So, back in december, I set up a subversion repository, and I imported a
lot of different things into it.  Now, I'm having a bit of an
interesting problem.  The under-construction website that I've been
working on is currently only saved in subversion (not smart, perhaps,
but I didn't think that subversion would give me these problems).  Now,
while I can check out all the other projects stored in the repository,
it won't let me check out my website.  I'd really like to get my website
back though.  Here's the information that I have:

So, if I run:
svn checkout file:///src/svn/cs345
svn checkout file:///src/svn/evilwm
it works fine, and the files show up in their directory and such

However, if I run:
svn checkout file:///src/svn/website

it gives the following errors:
svn: Unable to open an ra_local session to URL
svn: Unable to open repository 'file:///src/svn/website'
svn: Unknown FS type 'bdb'

I found this:
and thought that might be the answer. So, I ran:
svnadmin recover /src/svn

However, it gave me the following errors:
Repository lock acquired.
Please wait; recovering the repository may take some time...
svn: Unknown FS type 'bdb'

I'm assuming it's having problems with the berkeley db, but I'm not sure
why, or why it wouldn't be having problems on the other projects in the
repository... I'm pretty sure that subversion is not using berkdb,
that's confusing me. 

I'm hoping that someone here knows more than I do about subversion and
can help me out with this, because I'm stumped

Thanks in advance

Erin Sharmahd           TuxGirl at
CS Student              Unix Users Group
PGP Fingerprint:
F352 FF41 EA0A 67E4 566B 3B5B E65A D3DC 083E 9336

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : 

More information about the PLUG mailing list