Solved -- Re: Perplexing nfs problem, mount permission denied.

Topher Fischer javert42 at
Fri Dec 2 11:38:13 MST 2005

Michael Torrie wrote:

>On Fri, 2005-12-02 at 10:42 -0700, Michael Torrie wrote:
>>I have a CentOS4 nfs (v3) server with a mounted disk on /Storage.  I
>>have nfs-export this mount-point to various clients.  Up until today it
>>worked fine.  Now on any of the client machines when I try to mount the
>>share it simply reports 
>>mount: server:/Storage failed, reason given by server: Permission
>>and the syslog on the nfs server reports
>>rpc.mountd: authenticated mount request from clientmachine:686
>>for /Storage (/Storage)
>>There is not mention in the log of any error.  In desperation I even
>>tried just exporting to *(rw).  Nothing.  I can't even mount the share
>>from the nfs server from localhost.  This one has me completely stumped.
>>There is no reason that it should not work.  Is there some daemon that
>>I've forgotten about that I should restart?  I've restarted portmapper,
>>the nfs daemons, the nfs lock daemon.  I have a vague memory of
>>something similar happening to me once before, but I can't remember how
>>I fixed it.
>>Any ideas would be appreciated.  Oh.  Selinux is off, so that's not the
>>problem.  Nor is it a firewall issue.
>Here is the solution for posterity
>The problem was that the special nfsd file system that mounts
>to /proc/fs/nfsd wasn't mounted.  I'm not sure how it gets mounted
>(maybe rc.sysinit does it?), but I added an entry to /etc/fstab to be
>none	/proc/fs/nfsd	nfsd	auto,defaults	0 0
>Once I did this, everything was completely happy.
>One final note.  Apparently the nfsd mount is started when you modprobe
>nfsd on RHEL4.  So on a reboot it would have been fine. In the meantime
>the fstab entry won't hurt anything.
Thanks for posting your solution.  I also had this problem on an RHEL4
machine, and the source I found that helped me fix it had me add both
these lines:
none        /var/lib/nfs/rpc_pipefs     rpc_pipefs      defaults        0 0
none        /proc/fs/nfsd                    nfsd               
defaults        0 0

I'm not exactly sure what either one is used for/by, but maybe this
could help someone else.

Topher Fischer
GnuPG Fingerprint: 3597 1B8D C7A5 C5AF 2E19  EFF5 2FC3 BE99 D123 6674
javert42 at

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: OpenPGP digital signature
Url : 

More information about the PLUG mailing list