Perplexing nfs problem, mount permission denied.

Michael Torrie torriem at
Fri Dec 2 10:42:25 MST 2005

I have a CentOS4 nfs (v3) server with a mounted disk on /Storage.  I
have nfs-export this mount-point to various clients.  Up until today it
worked fine.  Now on any of the client machines when I try to mount the
share it simply reports 

mount: server:/Storage failed, reason given by server: Permission

and the syslog on the nfs server reports

rpc.mountd: authenticated mount request from clientmachine:686
for /Storage (/Storage)

There is not mention in the log of any error.  In desperation I even
tried just exporting to *(rw).  Nothing.  I can't even mount the share
from the nfs server from localhost.  This one has me completely stumped.
There is no reason that it should not work.  Is there some daemon that
I've forgotten about that I should restart?  I've restarted portmapper,
the nfs daemons, the nfs lock daemon.  I have a vague memory of
something similar happening to me once before, but I can't remember how
I fixed it.

Any ideas would be appreciated.  Oh.  Selinux is off, so that's not the
problem.  Nor is it a firewall issue.


Michael Torrie <torriem at>

More information about the PLUG mailing list