installing Sun JDK on Fedora Core 4

Bryan Sant bryan.sant at
Fri Aug 26 10:48:06 MDT 2005

On 8/26/05, Russel Caldwell <caldr704 at> wrote:
> Hi,
> I'm trying to intall Sun JDK on a machine that has Fedora Core 4 on it
> but I'm getting a message that it can't run in graphical mode and it
> suggests running the installer in -console or -silent mode. When I run
> it in -console mode I get a similar message and when I run it in
> -silent mode it seems to install but I can't find the installed
> package afterwards. Does anybody have any suggestions on how to
> install it? Also, I've run into a Redhat document that suggests to
> manually install the Sun Java tarball but I have not been able to find
> a tarball. Does it exist and if so where is it?
> Thanks.
> Russ Caldwell

Which JDK is this?  Are you installing the 1.5 + Netbeans bundle from Sun?

If you are installing 1.4 or older on  FC4, you'll need to install the
xorg-x11-deprecated-libs rpm.

Anyway, to install the 1.5 JDK + Netbeans package execute the following:

$ xhost +local
$ su
# chmod +x <jdk package>
# ./<jdk package>


More information about the PLUG mailing list