Apache died???

S. Dale Morrey sdalemorrey at gmail.com
Tue Apr 9 09:18:02 MDT 2013

Hi Everyone,

I found a system called astpp that I thought might work better in the long
run than asterisk with a2billing would.  (The asterisk / a2billing setup is
very, very fragile).

I started with a clean RHEL 6.3 image.  The image had apache2 preinstalled.
I then went ahead and followed the standard download, extract, make and
make install process.  I followed the directions on the astpp site.


Anyways I got through the configure, make & install process with no
errors.  However when I went to start up apache I got this error.

Stopping httpd:                                            [FAILED]
Starting httpd: (13)Permission denied: make_sock: could not bind to address
(13)Permission denied: make_sock: could not bind to address
no listening sockets available, shutting down
Unable to open logs

I've checked with netstat and nothing is bound to port 80 or 8080 or 8081,
so I really don't know what it's problem is.

Now one thing that MIGHT be a source of problems is that this line in the
beginning of the install instructions...

rpm -Uvh http://dl.fedoraproject.org/pub/epel/5/`uname

The whole statement doesn't make a sense under 6 because it's trying
to add packages from 5??
I tried it with both a 5 and a 6 and it just fails.

However none of the yum calls failed, so my assumption is that this
guide was written for RHEL 5 and then changed to 6 later and possibly
those instructions got overlooked.

Any thoughts on what I can do to try and troubleshoot this apache
thing would be greatly appreciated.


More information about the PLUG mailing list