Perl Modules: CPAN vs Yum

Doran L. Barton fozz at hypermoo.com
Tue Jul 3 10:29:17 MDT 2012


On Monday, July 02, 2012 11:40:39 AM Jacob Albretsen wrote:
>  /usr/share/man/man3/Math::BigFloat.3pm.gz from install of perl-Math-
> BigInt-1.997-1.noarch conflicts with file from package
> perl-5.8.8-38.el5.x86_64 file /usr/share/man/man3/Math::BigInt.3pm.gz from
> install of perl-Math- BigInt-1.997-1.noarch conflicts with file from
> package perl-5.8.8-38.el5.x86_64 file
> /usr/share/man/man3/Math::BigInt::Calc.3pm.gz from install of
> perl-Math-BigInt-1.997-1.noarch conflicts with file from package
> perl-5.8.8-38.el5.x86_64
>         file /usr/share/man/man3/Math::BigInt::CalcEmu.3pm.gz from install
> of  perl-Math-BigInt-1.997-1.noarch conflicts with file from package
> perl-5.8.8-38.el5.x86_64
> 
> My reason for updating Math::BigInt is because Math::BigInt::FastCalc 
> complains about the version and fails bunches of test.  Although, if I 
> understand right, Math::BigInt is part of the core modules, and my spidy
> sense  tells me messing with those might cause more problems than it
> solves.

This is one thing that royally sucks about distribution-provided perl RPMs. 
They usually contain a number of CPAN modules as 'core' modules. When you 
upgrade one of those independently, conflicts arise. I will usually cautiously 
force an install of the newer version and cross my fingers.

-- 
Doran L. Barton <fozz at hypermoo.com> - Linux, Perl, Web, good fun, and more!
 "Visitors are expected to complain at the office between the hours of 9
  and 11 A.M. daily.  "
    -- Seen in a hotel in Athens



More information about the PLUG mailing list