linux kernel upgrade from 2.6.18 to 3.2.5

Michael Torrie torriem at gmail.com
Fri Feb 10 09:23:26 MST 2012


On 02/09/2012 06:24 PM, Make Compile wrote:
> Hi guys,
> 
> i've been wondering today if 2.6.18 kernel can be upgrade into its
> latest kernel release of 3.2.5 on centos 5.0 linux. any ideas? just a
> liitle bit plan to experiment one of my centos 5 box. Thanks

Will be fun.  Typically an order distro like CentOS 5 will have a very
hard time with a newer kernel.  There will be the odd incompatibility
between a vital userspace component (modprobe, mkinitrd) and the new
kernel.  So you will have to update some of those components as well,
which could be messy.  Things like libselinux, libaudit will need to be
updated as well, most likely.  Just so you know what you are getting into.


More information about the PLUG mailing list