MySQL install troubles.

Eric Jacobs eric at chomp.us
Fri Feb 4 12:41:14 MST 2011


Hello Plug,

I have been fighting with MySQL for a few days trying to get it installed correctly on my VPS. I have Apache down to a science and it gets installed to my liking with my move in script. The tough part for me now is getting mysql going.

I'm installing MySQL 5.1.53 with configure:
./configure \
--with-mysqld-user=mysqld \
--with-big-tables \
--with-ssl=/usr/bin \
--without-docs \
--enable-profiling \
--enable-local-infile \
--with-charset=utf8 \
--with-extra-charsets=binary,armscii8,ascii,latin1 \
--with-unix-socket-path=/var/lib/mysql/mysql.sock \
--with-zlib-dir=/usr \
--with-plugins=partition,archive,blackhole,csv,heap,innobase,myisam

It configures, compiles and installs just fine, but when i attempt to start it up, I get a heap of errors. On the first try it complains about /usr/local/var not existing, so I create it and retry, then it spits out:

# /usr/local/libexec/mysqld --user=mysqld
/usr/local/libexec/mysqld: Table 'mysql.plugin' doesn't exist
110204 12:29:33 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
(snip: innodb first start messages)
110204 12:29:33  InnoDB: Started; log sequence number 0 0
110204 12:29:33 [ERROR] Can't start server : Bind on unix socket: No such file or directory
110204 12:29:33 [ERROR] Do you already have another mysqld server running on socket: /var/lib/mysql/mysql.sock ?
110204 12:29:33 [ERROR] Aborting

110204 12:29:33  InnoDB: Starting shutdown...
110204 12:29:38  InnoDB: Shutdown completed; log sequence number 0 44233
110204 12:29:38 [Note] /usr/local/libexec/mysqld: Shutdown complete
#

The installation didn't create the socket file, and I'm not sure how to, but I don't think it should be starting this badly on a fresh install. Can anyone provide me with guidance here? The MySQL docs really push you towards RPMs, but I'm just not into that.

Oh yeah, and I'm using CentOS 5.5.


Thanks!
Eric


More information about the PLUG mailing list