hppa linux liveCD

Derek Davis derek.davis at gmail.com
Tue Jul 1 14:14:40 MDT 2008


On Tue, Jul 1, 2008 at 7:33 AM, Nicholas Leippe <nick at leippe.com> wrote:
> On Monday 30 June 2008, Derek Davis wrote:
>> On Mon, Jun 30, 2008 at 4:29 PM, Nicholas Leippe <nick at leippe.com> wrote:
>> > When you installed gentoo, which did you use? 32bit or 64bit?
>>
>> Ah, that may be my problem. When choosing a stage file, I chose the
>> one that was hppa2.0 rather than hppa1.1. I wonder if the 2.0 was a 64
>> bit one? So I was compiling the kernel with a 64 bit compiler, but
>> configuring it as 32 bit. Yikes, I may have to reinstall the system.
>
> I don't think that hppa2.0 vs hppa1.1 is the same as 64bit vs 32bit. I believe
> that's just like 586 vs 686. New instructions, different instruction timings.

Well, apparently how I compiled the kernel doesn't have anything to do
with it, because I used the same kernel that I boot the hard drive
with (so I know it works) and the CD won't boot that one either, with
the same error. So perhaps it's something about where I put the kernel
on the drive (I tried it in both the root and in /boot) or how it's
written there? Or maybe the boot loader itself? Any thoughts?



More information about the PLUG mailing list