Ubuntu, KDE and wireless weirdness?

Steve smorrey at gmail.com
Sat Sep 22 18:33:13 MDT 2007


Performed an fsck and it returned no problems.
Rebooted, and the problem resumed. (grr!)
I have now created a script to take eth0 and eth1 down and reset them.
I added the script to my current runlevel.
Problem is now resolved (boot time has obviously increased though).

Still I can't figure out what could have caused this to begin with.
Any thoughts are greatly appreciated!

Sincerely,
Steve

On 9/22/07, Steve <smorrey at gmail.com> wrote:
> So I've now gone through and found that the problem is really wireless related.
> The problem does not replicate when I plug directly into the LAN and
> let it bring eth0 up.
> But here is something really strange.
> After plugging it into the network, performing a reboot, and
> unplugging (from the network) and rebooting it again.
> Everything is now back to normal.
> I'm going nuts trying to figure out what caused this, I changed nothing.
> But at least the problem is resolved.
>
> I'm going to drop into runlevel 1 and do an fsck just to be on the safe side.
>
> On 9/22/07, Steve <smorrey at gmail.com> wrote:
> > Bah I'm an idiot.  I just realized I'm running Feisty not Edgy.
> > I've had Ubuntu on this laptop since Edgy was released tough, never
> > with any problems before.
> >
> >
> > On 9/22/07, Steve <smorrey at gmail.com> wrote:
> > > Sorry I should have said soft locked, not hard locked.
> > >
> > > i.e. I can move the mouse, press buttons etc.  It's just that other
> > > than ctrl+alt+f(whatever), none of the keypresses produce a result
> > > (for instance the meta key, normally brings up the K menu, in this
> > > state it does nothing).
> > >
> > > I can however drop into bash using ctrl+alt+f1and resolve the lock up
> > > by by manually bringing up my wireless.
> > >
> > > I didn't go into any hardware specifics, because I don't feel this is
> > > a hardware issue.
> > > My best guess at this point is something in a recent update changed
> > > the order in which things are brought up.
> > >
> > > Where as before, my networking was brought up prior to run level 5.
> > > It's looking more and more like the recent update (or possibly
> > > something else which I can't yet figure out), has changed it so
> > > wireless networking is not brought up until after run level 5 is
> > > reached.
> > >
> > > For some reason, something in KDE is holding up the whole works until
> > > it does something that evidently needs my wireless networking to be up
> > > and running (note I have not tried this with wired yet)
> > >
> > > Anyways thats my line of thinking right now.  All I can think to do at
> > > this point is find out everything involved in my boot sequence and
> > > what is running at what run levels.
> > >
> > > Sincerely,
> > > Steve
> > >
> > >
> > > On 9/22/07, Charles Curley <charlescurley at charlescurley.com> wrote:
> > > > On Sat, Sep 22, 2007 at 04:20:25PM -0600, Steve wrote:
> > > > > Hey everyone,
> > > > > I've been running ubuntu edgy without any problems on my Dell C840
> > > > > laptop, since edgy was released.
> > > > > Today though I've started having some weirdness.
> > > > > Essentially what happens is I boot up, KDM runs as normal, then I log in.
> > > > > When I log in KDE comes up and then the system essentially hard
> > > > > freezes for a few minutes.
> > > > > No matter what I go to run, nothing will launch. And
> > > > > ctrl+alt+backspace does not work.
> > > >
> > > > You aren't very specific on your hardware or software. So I'll hazard
> > > > a few guesses.
> > > >
> > > > If you have Ethernet as well as wireless, can you SSH in to the
> > > > computer while the screen is locked up?
> > > >
> > > > If you are running Network Manager, you should have the latest and
> > > > greatest of NM and your kernel, and any firmware for your wireless
> > > > card. On Fedora I am running:
> > > >
> > > > kernel-2.6.22.5-76.fc7.i686
> > > > NetworkManager-0.6.5-7.fc7.i386
> > > >
> > > > You might try an Ubuntu 7.04 live CD or a 7.10 alpha prerelease live
> > > > CD. 7.10 is supposed to have the 2.6.22 kernel, which I've been
> > > > pleased with for wireless.
> > > >
> > > > --
> > > >
> > > > Charles Curley                  /"\    ASCII Ribbon Campaign
> > > > Looking for fine software       \ /    Respect for open standards
> > > > and/or writing?                  X     No HTML/RTF in email
> > > > http://www.charlescurley.com    / \    No M$ Word docs in email
> > > >
> > > > Key fingerprint = CE5C 6645 A45A 64E4 94C0  809C FFF6 4C48 4ECD DFDB
> > > >
> > > >
> > > > /*
> > > > PLUG: http://plug.org, #utah on irc.freenode.net
> > > > Unsubscribe: http://plug.org/mailman/options/plug
> > > > Don't fear the penguin.
> > > > */
> > > >
> > > >
> > >
> >
>



More information about the PLUG mailing list