Weird keys problem in FC5

Charles Curley charlescurley at charlescurley.com
Fri Sep 8 17:12:16 MDT 2006


On Fri, Sep 08, 2006 at 03:23:40PM -0600, Steve Meyers wrote:
> Barry Roberts wrote:
> > This has been annoying me since I started using FC5, and just this
> > week, I finally figured out why it works sometimes and not others.
> > 
> > I use emacs' chords like end-of-buffer a lot.  Normally that's bound
> > to Meta+> (Alt+>, i.e.  Alt+Shift+.).  Sometimes it works, sometimes
> > it's just like typing a ">" character. A few days ago I finally
> > figured out that what makes the difference is the order I chord the
> > Alt and Shift.  If I Shift first, then Alt, I get a ">" character.  If
> > I Alt first, then Shift, it works as expected.
> > 
> > This is the same for several Alt+Shift chords I've tried and it does
> > in a GNOME desktop and fluxbox.  It happens on emacs (or other
> > programs) running locally, remote X via ssh, and in an ssh term.
> > Anything displaying on the X server on my machine.  From a text
> > console the order doesn't matter.
> 
> I have a similar problem.  I use the windows key for a couple of things,
> and sometimes in FC5 it doesn't work as a meta key.  X recognizes when I
> press down the windows key, but it doesn't pass it as a modifier when I
> press something else while keeping the windows key down.  If I log out
> and back in a few times, I can eventually get it to work.
> 
> I filed a bug report for it back when I switched to FC5, but I haven't
> heard anything since then.

I found the same thing and filed a related bug on Gnome (I hadn't
figured out the bit about the sequence in which you put your fingers
down). But I don't think it's a Gnome or X issue. I think it's a
kernel issue (??). I fell back to 2.6.16 on my laptop for unreleated
issues, and lo, the problem went away.

See https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=189120 for a
workaround.

-- 

Charles Curley                  /"\    ASCII Ribbon Campaign
Looking for fine software       \ /    Respect for open standards
and/or writing?                  X     No HTML/RTF in email
http://www.charlescurley.com    / \    No M$ Word docs in email

Key fingerprint = CE5C 6645 A45A 64E4 94C0  809C FFF6 4C48 4ECD DFDB
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://plug.org/pipermail/plug/attachments/20060908/0bd45c5d/attachment.bin 


More information about the PLUG mailing list