Mozy Contest Answers

Alex Esplin alex.esplin at gmail.com
Sat Nov 4 20:56:02 MST 2006


On 11/4/06, Daniel C. <dcrookston at gmail.com> wrote:
> I think that
>
> if (foo) { do something }
>
> looks quite nice.  For multi-line statements though,
>
> if (foo) {
>     do_this;
>     do_that;
> }
>
> is the only way to do things.

Yeah, I really don't think it is the _only_ way to do things.  As was
mentioned above, personal preference plays a big part.  For me
personally, the following is more readable

if(foo)
{
    do_this;
    do_that;
}

Even though this is my personal preference, I will freely grant that
it isn't the _only_ way.  Coding style is something that someone will
always disagree with, no matter what style is chosen.  since both ways
are syntactically correct I can agree to disagree about which one is
"better" (and write a vim script to change a file to the way I like)
:-)

-- 
Alex Esplin



More information about the PLUG mailing list