RPM error - error: %pre(dbus-0.22-12.EL.2.i386) scriptlet failed, exit status 255

Mitch Anderson mitch at metauser.net
Thu Jun 16 15:34:02 MDT 2005


Mitch Anderson wrote:

> K,  I've had this error before, on a different system but it wasn't an 
> important system and I needed to test the latest release of 
> RHEL(centos) so I just wipped it and its been fine since.
> However, now I'm getting this error when doing a yum upgrade on a Dell 
> PE1650, running CentOS 4.
>
> error: %pre(dbus-0.22-12.EL.2.i386) scriptlet failed, exit status 255
> error:   install: %pre scriptlet failed (2), skipping dbus-0.22-12.EL.2
>
> Updated: dbus.i386 0:0.22-12.EL.2
> Complete!
> [root at trinity sysconfig]# rpm -V dbus
> ........?   /usr/bin/dbus-cleanup-sockets
> ........?   /usr/bin/dbus-daemon-1
> ........?   /usr/bin/dbus-send
> ........?   /usr/lib/libdbus-1.so.0.0.0
>
> Only it doesn't update the RPM. Its more than just this RPM, and I've 
> deleted it and redownloaded it a couple times with the same result.  
> I've googled for a while and haven't turned up anything to promising, 
> I've deleted the /var/lib/rpm/__db* files and ran "rpm --rebuild".
> Anyone else run into this?  harware problems?
> Any insites would be helpful.  I haven't brought it down yet to 
> perform an fsck on the disks yet, but I'm not sure that will fix this, 
> or will it?
>
Oh, and it doesn't matter if SELinux is in "enforcing" or "permissive" 
mode.  (changed it with setenforce Permissive/Enforcing)





More information about the PLUG mailing list