problem accessing/starting secure layer (https)

bibhor dhungel bibhor at gmail.com
Tue Jul 12 16:56:05 MDT 2005


i will look at the "ca-bundle.crt" too but these are the results from
the various commands. i dont think port 443 is open at all from the
results of these commands.
======================================================
[root at dedicated ~]# nmap localhost
Starting nmap 3.70 ( http://www.insecure.org/nmap/ ) at 2005-07-12 18:47 EDT
Interesting ports on localhost.localdomain (127.0.0.1):
(The 1652 ports scanned but not shown below are in state: filtered)
PORT     STATE  SERVICE
21/tcp   closed ftp
22/tcp   open   ssh
53/tcp   closed domain
80/tcp   open   http
110/tcp  closed pop3
143/tcp  closed imap
8080/tcp closed http-proxy
9999/tcp open   abyss

Nmap run completed -- 1 IP address (1 host up) scanned in 19.705 seconds
============================================================

[root at dedicated ~]# netstat -nl | grep ":443"
tcp        0      0 0.0.0.0:443                 0.0.0.0:*             
     LISTEN
============================================================
[root at dedicated ~]#netstat -nlp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address               Foreign Address       
     State       PID/Program name
tcp        0      0 0.0.0.0:9999                0.0.0.0:*             
     LISTEN      3542/urchinwebd
tcp        0      0 0.0.0.0:111                 0.0.0.0:*             
     LISTEN      3249/portmap
tcp        0      0 127.0.0.1:5335              0.0.0.0:*             
     LISTEN      3468/mDNSResponder
tcp        0      0 127.0.0.1:25                0.0.0.0:*             
     LISTEN      3525/sendmail: acce
tcp        0      0 0.0.0.0:443                 0.0.0.0:*             
     LISTEN      6233/httpd
tcp        0      0 :::80                       :::*                  
     LISTEN      6233/httpd
tcp        0      0 :::22                       :::*                  
     LISTEN      3497/sshd
udp        0      0 0.0.0.0:5353                0.0.0.0:*             
                 3468/mDNSResponder
udp        0      0 0.0.0.0:111                 0.0.0.0:*             
                 3249/portmap
Active UNIX domain sockets (only servers)
Proto RefCnt Flags       Type       State         I-Node PID/Program
name    Path
unix  2      [ ACC ]     STREAM     LISTENING     7696  
3621/dbus-daemon-1  /var/run/dbus/system_bus_socket
unix  2      [ ACC ]     STREAM     LISTENING     7640   3595/xfs     
      /tmp/.font-unix/fs7100
unix  2      [ ACC ]     STREAM     LISTENING     7386   3488/acpid   
      /var/run/acpid.socket
================================================
Is there a way to open port 443, or for that matter start openssl
explicitly with some command line. Openssl was installed with some
rpm-package (it was there when we got the server). thanks
bibhor



More information about the PLUG mailing list