installing perl modules and/or perl

bibhor dhungel bibhor at gmail.com
Thu Jul 7 00:25:37 MDT 2005


hi,
i am trying to install WWW::Mechanize module in the new server running
fedora core2. The 'perl Makefile.pl' and 'make' seem to run fine
except when i run 'make test' the server seems to stop forever at this
step after these lines:
#######################################
t/00.load...............ok 2/2# Testing WWW::Mechanize 1.12
t/00.load...............ok
t/add_header............ok
t/aliases...............ok
t/area_link.............ok
        4/9 skipped: Test::Memory::Cycle not installed
t/autocheck.............skipped
        all skipped: Test::Exception required to test autocheck
t/clone.................ok
t/die...................skipped
        all skipped: Test::Exception required to test die
t/field.................ok
t/find_image............ok
t/find_link-warnings....skipped
        all skipped: Test::Warn required to test t/find_link-warnings.t
t/find_link.............ok
t/form-parsing..........ok
t/frames................ok
t/image-parse...........ok
t/link-base.............ok
t/link-relative.........ok
t/link..................ok
t/live/back.............ok
        1/32 skipped: Test::Memory::Cycle not installed
t/live/click............ok
t/live/follow...........ok
        1/11 skipped: Test::Memory::Cycle not installed
t/live/follow_link......ok
        1/7 skipped: Test::Memory::Cycle not installed
t/live/form.............ok
t/live/get..............ok
        1/26 skipped: Test::Memory::Cycle not installed
t/live/reload...........ok
        1/13 skipped: Test::Memory::Cycle not installed
t/live/submit...........ok
        1/9 skipped: Test::Memory::Cycle not installed
t/local/back............ok 3/38# Started http://localhost:42084/
t/local/back............ok 4/38#     Failed test (t/local/back.t at line 51)
t/local/back............NOK 6#     Failed test (t/local/back.t at line 57)
Use of uninitialized value in concatenation (.) or string at
/usr/local/perl/WWW-Mechanize-1.12/blib/lib/WWW/Mechanize.pm line
1743, <$server> line 1.
Can't find any link matching Images on this page () at t/local/back.t line 63
#     Failed test (t/local/back.t at line 64)
t/local/back............ok 11/38No form defined at t/local/back.t line 71
t/local/back............ok 12/38
#######################################
Even after installing 'Test::Memory::Cycle','Test::Exception',
'Test::Warn' the 'make test' process seems to halt at this step and it
doesnt care if i am doing this using MCPAN or by downloading the
package. I have tried to remove the whole perl package using yum and
when trying to reinstall just perl i am confused as to which package i
should choose (i am using fedora core's repository:
http://download.fedora.redhat.com/pub/fedora/linux/core/$releasever/$basearch/os/)?
thanks



More information about the PLUG mailing list